No, Nighthawk. I’m not receiving you. I’m sending you back to Amazon!

My British Gas smart meter and Hive system went offline – again, and I’m putting the blame firmly on the Netgear X10 Nighthawk router – the one that looks like Hela from Thor: Ragnarok.

On Saturday morning I awoke to find that the British Gas Smart Meter had taken itself offline along with the Hive thermostat and receiver (and subsequently the app). Another call to Hive support eventually got things going again, but this time I was informed that the signal strength was all over the place.

However, I have a bone to pick with Centrica and Hive support – they’ve moved their support pages without setting up 301 redirects. The result is this – a massive SEO fail:

One problem I did have after getting the system back online was that one of the Hive lightbulbs had stopped responding. My living room’s front light. So I had to turn the lighbulb on and off 7 times before it reset and was able to be picked up by the Hive system again. As these lightbulbs act as a signal booster, I was wondering if these things had any part to play in all these problems. Whenever there have been a problem with the Hive system, the lights on my Netgear ProSAFE switch were constantly flashing – all at the same time – and in time with each other. Rebooting the Netgear Nighthawk fixed this, and things settled down to their regular on/off blinking.

So I decided to send the Nighthawk back to Amazon. And this is an odd thing. Amazon sent the thing via DPD. In order to return it, I have to drop it off at a Hermes drop-off place, or via the Royal Mail. It’d be nice, given the heft of the product, if Amazon could pick it up.

I’ve been using the Fritz! Box again for the past couple of days and haven’t had any dropouts from the British Gas smart meter or Hive. I am going to try the Amplifi HD mesh system which costs slightly less than the Netgear router, but should – hopefully – be a considerably better performer. The manufacturer of the system, Ubiquiti Networks, is a highly respected company within the networking community.

In fact, I specified and arranged the purchase of their UniFi system at work. And all that was based around on the antics of MarzBar (Alex Brooks) who, at the age of 18 set-up an entire WISP (wireless internet service provider) and uses Ubiquiti kit extensively. And here’s Alex explaining how the Amplifi system works:

I like technology when it works. But when it doesn’t, which is often, I feel the time and money spent on it could have been put to better use.

For the past couple of weeks, my British Gas Smart Meter has been somewhat unreliable. One evening it disconnected itself from the network. I assume that there was a problem with the 3G connection which caused the problem, but it was off for a good number of hours. It came back online the following morning, thankfully.

The same thing happened yesterday, but it also took down the Hive system too. Okay, I doubt is what actually happened, but it’s very spooky that both issues happened at the same time…

The computer says no…

When I went to check the boiler, the Hive receiver had a right light..

Choose life. Choose a replacement thermometer from Worcester Bosch. Choose a Hive thermostat from British Gas…

What followed was a series of multiple reboots of the Hive hub, multiple re-pairings of the receiver (shown above) and the thermostat, and while the receiver and the thermostat eventually talked to each other again, the app/hub wouldn’t acknowledge that the heating system was online. The app kept showing heating as being offline, but I could still operate the thermostat directly.

So I had to work from home today to give Hive technical support a call. They had me go through the same process, but they had to get the Hive hub (which is connected via ethernet via a switch which, in turn, is connected to the Netgear router) to re-pair as well. I’m not sure whether this is something that only Hive technical support can do, but there certainly wasn’t any user instructions that I could find to do this.

And this leaves me rather concerned. Hive technical support can look at my existing devices and turn them on or off. You are effectively handing control of your home to a third party. I’m now quite concerned about taking out any additional Hive products – especially the security cameras.

Anyway…

The technical support agent got everything re-paired again. Only to find out later that the app was out of sync with the thermostat. So I called Hive technical support again and was advised to reboot the hub. Which resolved the issue. They also upgraded the firmware of the hub. Which involved another reboot. But – touch wood – this has resolved the issue and everything is working as before.

Look. I can absolutely respect the outcome of the original referendum – that’s what the people voted for. But the subsequent clowning around and revelation that the Leave campaign outright lied is a massive cause for concern. And yet despite all this, that “bloody stubborn woman” is going beyond stubbornness and becoming downright suicidal with this country’s future and reputation.

Theresa May has point blank refused to listen to the country throughout the two year negotiation period which has lead to fumbling around and utter chaos in the Government and Parliament because she is working to her own agenda. She is not putting this country first. She is not giving the people what they want. She is not giving the Brexiteers what they want, and she is not giving the Remainers what they want. We all lose.

I believe it is better to remain in Europe where we have a voice and have the ability to influence matters (more so if we get the right people in as MEPs to represent us). What has been the result of two years of bungling has proven that we are a laughing stock of the world – alongside the USA – where we can’t even organise a piss up in a brewery, let alone organising a series of separate trade agreements along with the Northern Ireland border. If we impose a hard border on Northern Ireland, I’m pretty sure we’ll return to the bad old days.

We should – at the very least – remain in Europe until we can absolutely determine, beyond any doubt, that Brexit is a good thing. So far from what I’ve been reading and listening to, it isn’t. And it isn’t because this government has been a bloody farce.

That’s all I’ve got to say on this matter. The Conservatives have got to do what’s right – ditch May, replace her with somebody who actually listens to people and understand that people can change their minds. Somebody who understands about international law (especially trade law). Somebody who actually knows what the hell they’re doing – in other words.

Bring back the Monster Raving Loony Party is what I say.

The first thing you’ll notice about the Netgear R9000 router is how much larger it is compared to other routers. You’ll also notice that it kind of looks like Hela from the film Thor: Ragnarok, what with the big, thick antennae poking out from back and sides of the machine.

Which is which? Difficult to tell..

It took some effort just to get the blasted thing out the packaging. But once you’ve got it out the box and plugged in, it’s an extraordinarily easy experience to get it up and running.

The box is nearly as big as my Drobo’s box
A router so premium, it’s on its own pedestal…

You have a choice of configuring the Netgear via the web interface or via an app on your phone. I chose to use the web interface. A quick set-up wizard prompts you to connect to your ISP. It was able to detect the encapsulation required, and prompt me for my ISP username and password.

Once connected, speed tests weren’t that much different from the Fritz! box, and having done a bit of digging around with the Netgear app, despite the line of sight, I’m only achieving 62% signal strength from my Mac. I also noted something really odd about the Mac. Link speed is 54Mbs despite the transmission being over 800Mbs?

54Mbs link speed on the Mac, yet connected to 802.11ac?
MacOS Mojave’s Network Utility confirms link speed

If there’s one thing I’ve noticed over the years being an Apple owner – Apple’s Wi-Fi hasn’t been terribly great with different third-party routers and Wi-Fi. Over the years when I’ve had PCs, they seem to have done a better job working with different router manufacturers. That said, when I had Virgin Media and their 300Mbs broadband connection, the SuperHub 3.0 (which is made by Netgear) never had any issues.

I’m intending on moving the router away from the brick wall and to the centre of the room. In order to do this, I’ll need 2 x 5m Cat6 cables in order to bridge the Netgear ProSafe switch where the TV, Apple TV, Sony UltraHD Blu-Ray player and the Hive Hub all reside along with the G.Fast modem. It should provide a stronger Wi-Fi signal, though I’m considering just connecting the Mac via ethernet. By bringing the router closer, it’ll make it much easier to hook it up without too much cable mess.

The Netgar Genie app conveniently maps your network and provides stats for each device.

That said, the HP printer works perfectly fine with the Netgear. With the FRITZ! Box, it constantly dropped off the network. Now it’s rock solid.

Netgear Genie apps shows signal strength of each device.

The router has confirmed that it has been able to connect to the full negotiated speed of the broadband connection here, using the Netgear Nighthawk app. Ookla speed tests from the Apple TV show regular download rates of around 122Mbs.

Even with a less than ideal signal strength, the MacBook Pro is able to achieve decent download rates – again, around 122Mbs – from the likes of iTunes and Steam.

Overall I have been very impressed with this router (and less so with the MacBook Pro), and it has a lot more tricks up its sleeve. I’ll be covering some special features that this router has that no other router has in another blog post soon.

On Tuesday I had BT Openreach pop around to convert my master telephone socket to cope with the new G.Fast protocol which allows me to download speeds up to 330Mbs and upload up to 50Mbs (though I’ve gone with a package that offers up to 160Mbs down, 30Mbs up).

ALAS!

While everything checked out on the master socket, and a new fancy faceplate fitted, Openreach didn’t have sufficient instructions from Zen Internet to be able to test internet connectivity. It turns out that the FRITZ! Box 7350 doesn’t contain a G.Fast modem. It can support VDSL up to 300Mbs, but itself cannot handle the protocol. So Openreach had to pull out a – controversially some would say (though I have no problem with the company or its products) – a Huawei MT992 G.Fast modem. A white box that connects to the DSL line with an ethernet port to connect to LAN 1 on the FRITZ! box. Openreach had the PSU and the box itself, but strangely not a RJ-11 DSL cable. So I nicked the one from the Sky Broadband router.

The next part was to figure out how to get the FRITZ! box routing through the LAN rather than the DSL connection. The Openreach engineer called Zen and they talked me through doing so. After a while, the router established a working internet connection and all was well. Or so I thought. Initial speed tests were showing 100Mbs down, and 27/28Mbs up. Upload speed is fine, but I’m missing a potential whopping 60Mbs. We made sure that the cable between the FRITZ! Box and the Huawei modem was capable of gigbit speeds, and that LAN1 LAN port was set to gigabit speed. It was.

The Openreach engineer left – he tested the line and demonstrated it was connecting at expected speeds. I, meanwhile, took the MacBook Pro and hooked it up to ethernet with Cat6 cable to LAN port 3. I achieved a maximum of 140Mbs down – an improvement over the Wi-Fi test. Single thread download, however, wasn’t pleasant – around 37Mbs. Since the majority of multimedia stuff is going to me multithreaded anyway – this isn’t too big of a problem for me – but hardly the stuff that Sky Broadband was offering at £12 less per month.

One extremely annoying problem that cropped up with the FRITZ! box was that my HP OfficeJet printer would not establish a stable connection via Wi-Fi despite being line of sight of the router. No matter what changes I made to the FRITZ! box’s Wi-FI settings, or ensuring it received the same IP each time, it would not hold connection. I had a pear of Netgear powerline adaptors to hand and hooked up the printer via ethernet – a ridiculous situation given the Sky Q Broadband router had no trouble with this at all. I had restarted the printer several times too. But with the powerline adaptors in place, the printer was finally on the network. It should be noted that I changed all of the FRITZ! box SSID and WPA passwords to match the old router to try and avoid having to reconfigure all my devices – by and large it worked. Even my “smart” scales connected just fine. But the HP printer? What a stubborn git.

The FRITZ! Box definitely seems to have some strange ideas over QoS, Wi-Fi channel management – but it has terrible throughput/range. With my iPhone and iPad upstairs, I achieve less than half speed of that downstairs. Signal strength seems strong, but throughput is not what I thought it would be. Definitely much weaker than previous routers I have used.

I’m shortly going to be testing a Netgear X10 Nighthawk R9000 router. This is a flipping expensive piece of kit – more expensive than many of Draytek SOHO routers that I’ve been using on and off over the past (nearly) 2 decades. But as I have a Netgear ProSAFE switch to hook up all my wired kit, and previous ISP provided routers have been rebadged Netgear routers which have worked very well, it seems sensible to invest in something that I hope will last 3-4 years and provide good range and throughput. If it doesn’t do what I hope it will do, it’s going right back. I need a stable home network & internet access for work AND play, and I’ll pay what I need to get it – though I will frown upon Zen’s choice of router if this thing fixes all the problems.

BTW, in Zen Internet’s customer portal it’s possible to find stats relating to the connection. I’m currently connected at 146981Kbs which equates to the kind of speeds I was seeing when connected via ethernet.

However, last night I did see substantial performance problems during the evening in which I couldn’t get download speeds above 30Mbs and upload speeds of around 10Mbs. Whether this was Wi-Fi or the broadband connection itself, I can’t say as yet. We’ll see what kind of speeds we get with the Nighthawk.